Twyll performance degraded
Resolved
Jan 23 at 05:15pm EST
Between 2PM-7PM EST on Friday, January 19, 2024 and 10:45AM-8:30PM EST on Monday, January 22, 2024, Twyll users may have experienced slower response times due to a small degradation in performance. The issue was resolved on Tuesday, January 23, 2024, at 1:35PM EST. We identified that a new feature caused this problem, so we deactivated it. We're now working to fix the feature and ensure it won't affect Twyll's performance in the future. We apologize for the interruption and are enhancing our processes to prevent such incidents in the future.
Affected services
twyll.app
Updated
Jan 23 at 01:36pm EST
We have released several product updates that have resolved the outstanding performance issues. We will continue to monitor performance and provide a postmortem for this incident.
Affected services
twyll.app
Updated
Jan 23 at 12:25pm EST
Users may notice slow load times for clients with a large number of task analysis targets. We are working on a product update to address load times.
Affected services
twyll.app
Updated
Jan 23 at 11:41am EST
Users may notice slow load times for certain clients when loading the in session experience. We are continuing to monitor performance and will be releasing another product update shortly to address load times.
Affected services
twyll.app
Updated
Jan 22 at 11:31pm EST
The infrastructure changes have been completed and access to Twyll has been restored. We are currently monitoring performance.
Affected services
twyll.app
Updated
Jan 22 at 10:11pm EST
We will be making some infrastructure changes today from 11-11:30PM EST. During this time, Twyll will be unavailable. We will provide an update once access to Twyll is restored.
Affected services
twyll.app
Updated
Jan 22 at 07:42pm EST
We are still actively working on the issue. The next update will be provided after 11PM EST.
Affected services
twyll.app
Updated
Jan 22 at 06:17pm EST
Investigation is still ongoing and we will provide another update within the hour.
Affected services
twyll.app
Updated
Jan 22 at 05:05pm EST
The hotfixes that were released did not resolve the performance issue and we are further investigating. We will provide another update within the hour.
Affected services
twyll.app
Updated
Jan 22 at 04:01pm EST
We are currently in the process of releasing a couple of hotfixes to correct the performance issue. Another update will be provided within the hour.
Affected services
twyll.app
Created
Jan 22 at 04:00pm EST
We are currently investigating a performance issue that may be causing Twyll to be slower to respond. We are actively working on it and will provide regular status updates every hour.
Affected services
twyll.app